2016 15" MacBook Pro (RP455) [6th,4C,H] + RX 5700 XT @ 32Gbp... (2024)

August 13, 2020 4:06 pm

System specs + eGPU hardware

I think the title covers the most. But in addition, I am using the standard small TB3 cable that came with the enclosure. And the GPU is driving a DELL P2319H 23-inch (1920 x 1080).

I believe I am the only entry at the moment that has this setup, AKiTiO Node Pro and 5700 XT. I had some initial concerns about the graphic card requiring 600W+ while the PSU in the AKiTiO Node Pro is only 500W and only 400W of those are actually going into the GPU. But it works without problems. Even if not, the PSU is replaceable since it is a standard "small" sized PSU as far as I read about it. I also use the 87W macbook charger directly so I think that lessens the burden on the PSU as well (does it?).

Installation steps

As for guides, I generally followed the bootcamp setup guide but I also read about a million of them so sometimes a step in the guide didn't really click until after reading another one. My first attempt resulted in W10 not booting at all.

But my second attempt worked flawlessly and I actually recorded the full setup (minus installing windows). So the installation steps includes timestamps in case you want to see it in action.

https://youtu.be/R8-VrTjqQig

Thebold steps are basically what I think is the required steps, but I also annotated everything else as well.

01 - 00:00:00 Just finished installing Windows
02 - 00:00:50 Checking initial device state after install
03 - 00:01:16 Create a restore point
04 - 00:04:28 Check exact windows version
05 - 00:06:17 Update windows to build 18362.295
06 - 00:18:00 Finish version update and check device manager again
07 - 00:19:00 Boot to macOS
08 - 00:30:18 Partition HDD for automate-eGPU EFI files
09 - 00:43:54 download the files
10 - 00:45:58 Read about wether I need to put the UDID into the config file
11 - 00:55:56 Add UDID of disk into boot plist(Not sure if this is needed, but I did it anyway)
12 - 00:55:04 Realize I did not create a FAT partition
13 - 00:56:31 Make a FAT partition
14 - 01:03:06 Add automate-EFI to new partition (with the boot key in plist)
15 - 01:03:55 Reboot to normal windows NOT EFI
16 - 01:04:03 Check device manager
17 - 01:04:19 Reboot to SAFE mode
18 - 01:06:06 Run DDU and restart
19 - 01:07:57 Check device manager (note that graphics card is generic name)
20 - 01:08:27 Download HWiNFO to check thunderbolt ports
21 - 01:13:18 Create restore point
22 - 01:20:20 Download pre-compiled DSDT override for my specific macbook
23 - 01:26:23 Move and rename "dsdt-modified.aml" → "/EFI/CLOVER/ACPI/WINDOWS/dsdt.aml" file into FAT partition
24 - 01:27:23 Reboot into EFI mode
25 - 01:27:55 VERIFY that the DSDT fix actually works (large memory exists)
26 - 01:30:34 Install intel graphics for the integrated/dedicated laptop gpu
27 - 01:41:46 Reboot
28 - 01:42:46 Reboot again into EFI
29 - 01:42:46 Check device manager (it now shows intel graphics instead of generic name)
30 - 01:44:06 Restore point
31 - 01:44:30 Shut down
32 - 01:45:00 Connect eGPU for the first time
33 - 01:45:20 boot into EFI
34 - 01:45:53 See new device popup
35 - 01:46:20 Check device manager (now shows 3 eGPU with generic name)
36 - 01:46:51 Install AMD drivers from bootcampdrivers.com (check factory reset)
37 - 01:51:30 Reboots automatically
38 - 01:53:20 AMD driver install continues automatically
39 - 01:54:30 Check device manager (5700 XT now recognized by name! but has warning triangle and error code 12! because the automatic reboot did not reboot into EFI mode?)
40 - 01:56:10 Automatic reboots again
41 - 01:57:00 Reboot into EFI mode after the AMD install is finally done
43 - 01:57:50 External monitor starts! this means the GPU is working
44 - 02:04:08 Run benchmark
45 - 02:08:35 Benchmark results

Misc

I seem to have to use the lower left port, top left does not work when I boot to EFI mode.

I didn't disable any ports (well technically I did in my first try, but it doesn't persist through Windows installs does it? even after re-partitioning etc).

Benchmarks

Windows
5700 XT - FPS 117 / Score 2962 / Min,Max 9,195

macOS
5700 XT- FPS 95 / Score 2408 / Min,Max 12,195
iGPU/dGPU - FPS 20 / Score 518 / Min,Max, 7,38

Comments

Not really. Generally it works fine, makes unplayable into playable. It took a while to get the game I am playing to be working well though. I have some comments about it here and the game I play is Escape From Tarkov.

In summary, if I want to "up" my FPS more I'll likely buy a PC, but this is pretty okay for now.

2016 15" MacBook Pro (RP455) [6th,4C,H] + RX 5700 XT @ 32Gbps-TB3 (AKiTiO Node Pro) + macOS 10.15.5 & Win10 [build link]


footlooseboss, howoarang, nando4 and 1 people liked

ReplyQuote

2016 15" MacBook Pro (RP455) [6th,4C,H] + RX 5700 XT @ 32Gbp... (2024)

References

Top Articles
Latest Posts
Article information

Author: Ms. Lucile Johns

Last Updated:

Views: 6518

Rating: 4 / 5 (61 voted)

Reviews: 92% of readers found this page helpful

Author information

Name: Ms. Lucile Johns

Birthday: 1999-11-16

Address: Suite 237 56046 Walsh Coves, West Enid, VT 46557

Phone: +59115435987187

Job: Education Supervisor

Hobby: Genealogy, Stone skipping, Skydiving, Nordic skating, Couponing, Coloring, Gardening

Introduction: My name is Ms. Lucile Johns, I am a successful, friendly, friendly, homely, adventurous, handsome, delightful person who loves writing and wants to share my knowledge and understanding with you.